printfriendly

Thursday, September 19, 2019

Solved! My new Asus Zenbook with WIndows 10 Pro could not see my NAS device

Print Friendly and PDF


How I solved it

My NAS device is named OBI-WAN
  1. Found it on my old computer and swiped this: \\OBI-WAN\share
  2. On my new computer, clicked on Map Network Drive
  3. Paste into the folder name
  4. But I get this error message:
    The mapped network drive could not be created because the following error has occurred: You can't connect to the file share because it's not secure. This share requires the obsolete SMB1 protocol, which is unsave and could expose your system to attack. Your system requires SMB2 or higher. For more info on resolving this issue, see: https://go.microsoft.com/fwlink/?linkid=852747
  5. I found a workaround. You can enable the SMBv1 Protocol by doing this: 
    1. Open Control Panel
    2. Click Programs
    3. Click on Turn WIndows features on or off link
    4. Expand the SMB 1.0/CIFS File Sharing Support option.
    5. Check the SMB 1.0/CIFS Client option.
    6. Click the OK button.
    7. Restart the machine 
  6. Now try mapping the network drive again. It should work now.

However, there's a more secure way instead

Enable SMB2 in the web interface.

More info




I belong to a private, fee-based group of Pythonistas.

If you would like to know more about PythonistaCafe, where we share thoughts, ideas, fixes, and a sense of courteous community, look to Dan Bader, who started it all. He also offers free tips by email. Oh, and if you take an interest in good marketing writing, read his stuff for that reason too. 

No comments:

Post a Comment

Positive comments, corrections and clarification welcome.